Browsers must meet minimum security standards to access Internet Banking and must support Transport Layer Security (TLS) 1.2  If you have been redirected to this page and your browser does support TLS 1.2, log In here.

In the section below, we have provided options for you to consider when updating your browser. Once you have upgraded, please re-visit our website at www.peopleschoice.com.au.

People's Choice Mobile Banking apps and mobile friendly design 

Users who cannot upgrade their browser can still easily access our website and Internet Banking via their browser on a mobile device, such as smartphone or tablet. 

Members can also access Mobile Banking by downloading the People's Choice app for iPhone or Android.

 

How to upgrade your browser

If you are running an older browser, you will need to upgrade your web browsers. Find your browser in the list below and click on the name or the logo for more information on how to upgrade to the latest version.

Browsers supported by Internet Banking:

  • Microsoft Internet Explorer 11 and higher
  • Microsoft Internet Explorer Mobile (Windows Phone 8.1) 11 and higher

  • Microsoft Edge

  • Mozilla Firefox 27 and higher

  • Google Chrome 30 and higher

  • Google Android OS Browser Android 5.0 and higher

  • Apple Safari 7 and higher on OS X and up
  • Apple Safari Mobile 5 and higher on iOS 5 and up

  • Opera 17 and higher
  • Other browsers that support Transport Layer Security (TLS) 1.2 may be suitable

 

Is your browser is not listed? Call us on 13 11 82 and we can help.